A possible issue has been detected in SoftPro Hosted and an investigation is underway.
Incident Report for SoftPro Product
Resolved
This incident has been resolved.
Posted Sep 12, 2024 - 10:30 EDT
Investigating
We have received reports that some users may currently be experiencing issues authenticating to the SoftPro Hosted software. Our technical teams are aware and have been fully engaged to investigate the cause.
Posted Sep 12, 2024 - 09:24 EDT
This incident affected: SoftPro Select Hosted.