A possible issue has been detected in SoftPro 360 and an investigation is underway.

Incident Report for SoftPro Product

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 15:33 EDT

Monitoring

A fix has been applied and we are monitoring to ensure the issue is resolved.
Posted Mar 19, 2026 - 15:21 EDT

Identified

We are currently working to resolve this issue.
Posted Mar 19, 2026 - 14:59 EDT
This incident affected: SoftPro 360.